Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
DR-1 & MMDVM
#21
ja habe ich nachgeladen

in der doku steht das man IDE 1.6.8 und SAM 1.6.7 nehmen soll, die neuste IDE ist aber die 1.6.12 und dann soll man die SAM 1.6.9 nehmen, woher ich noch nicht weiß woher ich die bekommen soll

oder alles zurück und die alte IDE 1.6.8 nehmen, mal die Tage probieren

schon alles nicht so einfach aber aufgeben ist keine option Big Grin 

hast du deinen arduino am laufen ? welche versionen hast du IDE und SAM ?
Zitieren
#22
(02.11.2016, 17:15)DD3JI schrieb: schon alles nicht so einfach aber aufgeben ist keine option Big Grin
Tja, wenn die Ideen ausgehen, gibts nicht mehr viel andere Optionen.... Dodgy


Zitat:hast du deinen arduino am laufen ? welche versionen hast du IDE und SAM ?
Ich weiß ja nicht, ob der Arduino und das Modem funktioniert.
IDE habe ich 1.6.10, was is SAM?
FT-991 / FTM-400 / FT-1 / FT-1 / FTM-100
Zitieren
#23
Na dann frage ich weiter aber ich schmeiss das Zeug doch nicht einfach weg nur weil ich es auf Anhieb nicht hin bekommen Smile 

IDE ist wo das Programm und SAM irgendwas mit dem Core, aber frag mich nicht so so sachen, andere die sich auskennen
lachen sich bestimmt nun kaputt Big Grin
Zitieren
#24
so läuft  Big Grin 

Weihnachten gibts die Auflösung...Weihnachten 2050 natürlich Tongue 



Nein, natürlich nicht

Ich hab nun die IDE1.6.12 und SAM1.6.9 genommen, vorher alle alten Versionen deinstalliert und zusätzlich den Ordner
ARDUINO15 komplett von Hand gelöscht, das wir bei der Deinstallation nämlich nicht gemacht

Dann die platform.txt geändert und mmdvm.ino aufgerufen
die config.h geändert, speichern und kompilieren und siehe da, geht
dann den DUE dran, DUE und port auswählen, dann hochladen....zack blink die L-LED schön in orange und fertig

3 tage, ein wenig schimpfen, was externe Hilfe und geht

nun weiter im Programm....
Zitieren
#25
Also du hast das Modem auf einem Arduino und läßt das von einem Raspi steuern?
Und das Modem steuert was? Ein DR1?
Was steht in der "platform.txt". wo ist die, und was muss geändert werden?
Was hast du in der config geändert?
FT-991 / FTM-400 / FT-1 / FT-1 / FTM-100
Zitieren
#26
Zu erst einmal, heute weiteren Erfolg gehabt Big Grin 

Ich habe alles zusammengesteckt, also das Modem auf den DUE, den an den PI3 und Saft auf den PI3, dann startet der PI3 mit der Western Digital Software und dann in die "shell" rein und nach der Anleitung ganz genau vorgegangen http://wiki.bm262.de/doku.php?id=anleitung:mmdvm:host

Wichtig ist nur das man vorher sich als root anmeldet sonst geht es nicht !

Das wusste ich auch nicht und habe dann schnell Probleme bekommen weil Fehler auftraten, der Befehl in der shell "sudo su -" hilft weiter wenn man es als Neuling nicht weiß, hätte mehr geholfen wenn es in der Doku drin gestanden hätte.

Dann die MMDVM.ini angepasst mit den eigenen Werten, Display von NONE auf NEXION geändert ( ich hab eines am PI3 ), die DMR-ID eingegeben usw.

Das ganz läuft nun erst einmal bis auf die falschen/fehlenden IPs der Server für DMR/D-Star/C4FM etc., alle 10 Minuten wird die Bake aber ausgesendet ( TX LED geht dann an )
Zitieren
#27
(05.11.2016, 16:04)dj3ue schrieb: Also du hast das Modem auf einem Arduino und läßt das von einem Raspi steuern?
Und das Modem steuert was? Ein DR1?
Was steht in der "platform.txt". wo ist die, und was muss geändert werden?
Was hast du in der config geändert?

Der PI3 kommt an LAN und an einen der USB kommt der Arduino, auf den Arduino wird das Modem gesteckt, an das Modem kommt später der DR1 mit seiner 15poligen Leiste.

Den Arduino vorher alleine bespielen mit der MMDVM, in der platform.txt wird nur ein Eintrag ergänzt, dann IDE gestartet in dem Du mmdvm.ino anklickst und unter der config.h wird nur eingestellt welche
XTAL-QRG ( stehen schon alle dort drin müssen nur aktiviert und/oder auskommentiert werden mit # ) du hast und welches Modem, ZUM oder NTH.

http://wiki.bm262.de/doku.php?id=anleitung:mmdvm:due

Im Grunde ist es 3 Minuten Arbeit wenn es richtig gemacht wird ( ok ich hab auch ohne Ende probiert aber auch gelernt nun, das ist es
mir wert sich damit zu beschäftigen )

Die platform.txt ist im Paket enthalten und änderbar mit Wordpad, dann die mmdvm.ino anklicken, IDE geht auf und dann auf den Reiter config.h,
prüfen, kompilieren und hochladen auf das Board.

Nochmal, bis vor einer Woche hatte ich nullkommanull Kenntnisse von Linux und dem ganzen Zeugs Big Grin
Zitieren
#28
   
Übersicht
Zitieren
#29
(05.11.2016, 20:03)DD3JI schrieb: Der PI3 kommt an LAN und an einen der USB kommt der Arduino, auf den Arduino wird das Modem gesteckt, an das Modem kommt später der DR1 mit seiner 15poligen Leiste.
Bis auf einen WLAN-Dongle hab ich das soweit auch


Zitat:Den Arduino vorher alleine bespielen mit der MMDVM,
Ich habe den schon mit der Soft bekommen, hab die Soft aber nochmal drauf gespielt.


Zitat:in der platform.txt wird nur ein Eintrag ergänzt,
Ich konnte diese platform.txt noch nicht finden, was wird darin geändert?

Zitat:dann IDE gestartet in dem Du mmdvm.ino anklickst und unter der config.h wird nur eingestellt welche
XTAL-QRG ( stehen schon alle dort drin müssen nur aktiviert und/oder auskommentiert werden mit # ) du hast und welches  Modem, ZUM oder NTH.
Das habe ich soweit auch.


Zitat:Im Grunde ist es 3 Minuten Arbeit wenn es richtig gemacht wird...
Das freut mich für dich, bei mir sind es jetzt ungefähr drei Monate "Arbeit".
Ich kenn mich wenig aus und muss immer umständlich irgend jemanden per Email oder Forum fragen.


Zitat:Die platform.txt ist im Paket enthalten und änderbar mit Wordpad
In welchem Paket?
FT-991 / FTM-400 / FT-1 / FT-1 / FTM-100
Zitieren
#30
Na wenn Du den DUE doch schon bespielt hast kann dir die Änderung der platform.txt doch egal sein, ohne diese Änderung könntest Du den DUE doch nicht bespielen ?!

Ansonsten wird das hier beschrieben:

http://wiki.bm262.de/doku.php?id=anleitung:mmdvm:due

Bis auf die Änderung das ich die IDE1.1.12 und ZUM1.6.9 genommen habe.

und /jonathan/ musst Du natürlich durch etwas anderes ersetzen, je nachdem wo Du das Paket eingespielt hast

Unter WIN7 einfach die DOS-Shell aufrufen und den angepassten Link eingeben, dann kommst Du automatisch zu dem Unterordner.

Zu Deinen 3 Monaten, wenn Du schreibst das Du wenig Ahnung hast hast Du mehr als ich, ich hatte null Ahnung Big Grin

Einfach dran setzen und probieren und fragen, ich hab nach dem ich nicht weiter gekommen bin auch immer eine Email geschrieben und gefragt.
Zitieren
#31
Du hast weiter oben geschrieben, das Lochraster-Modem wäre das ZUM?
Ich habe das "weiße" Modem, das steht ZUM V1.0 drauf.
So habe ich das auch in der Config aktiviert.

Wie gesagt, die einzige "Reaktion", die das Modem zeigt, ist eine Rückmeldung, wenn ich MMDVM-Cal starte.
Also muss ja zumindest eine "Verbindung" zwischen Raspi und Modem bestehen.
Ansonsten tut sich Null-Komma-Nichts, weder an den Modem-LEDs noch an den Raspi-Meldungen.
Wie bereits mehrfch geschrieben, ich weiß ja nicht, mit welcher der zahlreichen Anwendung auf dem Raspi ich was und wie testen kann.
Deswegen weiß ich ja nicht, ob Modem und Arduino überhaupt "in Ordnung" ist.

platform.txt hatte ich schon geändert, das is so lange her, das ich mich schon nicht mehr dran erinnern konnte ;-)

Wo finde ich /jonathan/ und was muss da geändert werden ?


Angehängte Dateien Thumbnail(s)
       
FT-991 / FTM-400 / FT-1 / FT-1 / FTM-100
Zitieren
#32
OK, Du hast ein anderes Modem als ich, sieht man auf meinem Bild ja, das hier ist das nth-modem was man auswählen muss
in der platform.txt, ZUM meine ich wäre da standardmässig drin deshalb musste ich es ändern

Jetzt kann ich zu dem Verhalten des ZUM-Modem nichts sagen, meines zeigt nur die Versorgungsspannung an per LED und die PTT wenn die Bake gesendet wird per LED ( habe ja den Repeater nicht dran derzeit )
Allerdings geht auf dem DUE die Beleuchtung ziemlich hektisch, die L blinkt und die beiden LEDs neben der USB Buchse (RX/TX) rattern die ganze Zeit.

" Wo finde ich /jonathan/ und was muss da geändert werden ? "

Das brauchst Du doch auch nur für den DUE den Du doch schon fertig hast !

Wenn der DUE an dem PI ist spiel doch einfach mal mmdvm nach der Brandmeister-Doku drauf http://wiki.bm262.de/doku.php?id=anleitung:mmdvm:host, pass die mmdvm.ini an wie unter
http://wiki.bm262.de/doku.php?id=anleitu...:mmdvm.ini und dann sollte das laufen.

Die Links sind nun schon etliche Male genannt worden hier, probier es doch einmal....
Zitieren
#33
(07.11.2016, 16:58)DD3JI schrieb: Die Links sind nun schon etliche Male genannt worden hier, probier es doch einmal....

Ich habe die Links etliche Male durchgelesen und durch probiert.
Ich habe die mmdvm.INI schon längst nach Angaben angepasst.
Ich habe die Soft auf Arduino und Raspi mehrmals neu aufgespielt.
Ich habe angefangen, mich mit der Programmierung eines Arduinos zu beschäftigen in der Hoffnung, das ich das Ding etwas verstehe.
Ich habe eine config.h und platform.txt nach Angaben angepasst.
Ich habe von drei geduldigen OMs die Tipps und Ideen ausprobiert.

Wenn ich MMDVM-Host starte, kommt dieses Fenster und verschwindet kommentarlos wieder.
Dannach ist die Hardware "tot".
Hinzu kommt, das ich nicht weiß, ob und wie das Modem ohne eine Relais-DMR-ID überhaupt anläuft.

Frank, ich danke dir für deine Geduld und Mühe, aber ich dreh mich hier nur im Kreis.
Ich kann mich nicht erinnern, monatelang solch massive Probleme mit Funk- oder Computer-Hardware gehabt zu haben, ohne das ich irgendwann weiter gekommen bin.

Ich habe jetzt keine Lust mehr, es gibt noch andere Sachen im Hobby, mit denen ich mich erfolgreicher beschäftigen kann.
Ich werd den Kram wohl wieder verkaufen, natürlich mit Geld-zurück-Garantie, weil ich ja nicht weiß, ob ich das defektes verkaufe.
Vielleicht hat jemand anderes ja mehr Glück damit.

Nochmals Danke.
Achim


Angehängte Dateien Thumbnail(s)
   
FT-991 / FTM-400 / FT-1 / FT-1 / FTM-100
Zitieren
#34
Nun läuft der DR1XE mit dem MMDVM seit einigen Tagen und habe einige Parameter in der mmdvm.ini immer wieder experimentell
angepasst. Es läuft nun mit C4FM und D-Star, DMR muss ich noch angehen wenn ich Zeit habe.

TX_Level für alle Sendearten ging nicht einzustellen, also habe ich das Poti einfach 3 Umdrehungen geöffnet und dann per
Software die Pegel einzeln für DStar und C4FM angepasst, das ist in der Ini. schon vorgesehen:

DR1XE mit DL7TJ Modem Vers.1.1 ( im Anhang noch die Anschlussbelegung bei mir )

[Modem]
Port=/dev/ttyACM0
# Port=\\.\COM3
TXInvert=1
RXInvert=1
PTTInvert=0
TXDelay=150
DMRDelay=0
RXLevel=50            Poti RX einstellen bis die SQL an geht ( scheint bei allen Sendearten zu passen )
# TXLevel=50         wenn alle Pegel gemeinsam passen würden :-)
CWIdTXLevel=50
D-StarTXLevel=95   damit geht bei mir D-Star
DMRTXLevel=50      muss ich noch herausfinden
YSFTXLevel=65       damit C4FM
P25TXLevel=50       inaktiv
OscOffset=0
RSSIMultiplier=1
RSSIOffset=10
Debug=0


Angehängte Dateien Thumbnail(s)
       
Zitieren
#35
..ich bin mittlerweile mit OM Nr. 4 im Gespräch, aber auch er hat bisher noch nicht die richtige Zündung für mein Modem.
Ich gehe weiterhin davon aus, das das Modem defekt ist, was anderes kann ich mir nicht mehr vorstellen, nachdem ich rings um so gut wie alles ausgetauscht habe...

Wie ist das:
Bei einem DMR-Signal kann man mit einem Talkraum connecten, bei C4 mit WiresX und bei einer D*-Eingabe kann ich einen Reflektor anwählen?

Wenn der Repeater gerade vom Internet kommend am Senden ist, was passiert, wenn auf der Eingabe ein Signal kommt, in der gleichen Betriebsart oder in einer fremden?
FT-991 / FTM-400 / FT-1 / FT-1 / FTM-100
Zitieren
#36
Bie C4FM kann ich mich im YSF bewegen, also DL1 und DL2 connecten, bei D-Star ganz normal wie man es kennt, Reflectoren auswählen etc.
Voreinstellung was connectet werden soll wird in der .ini gemacht

Wenn was vom Netz kommt geht das vor, kommt nix mehr muss man die eigestellte Haltezeit abwarten und man bestimmt den neuen
Mode dann als User über die Eingabe.
Zitieren
#37
(26.11.2016, 06:10)DD3JI schrieb: Bie C4FM kann ich mich im YSF bewegen,
Ähm.....was genau meinst du damit? ;-)

YSF ist die Hausmarke....


Zitat:also DL1 und DL2 connecten,

Was is das?
FT-991 / FTM-400 / FT-1 / FT-1 / FTM-100
Zitieren
#38
@Achim

YSF is ja wieder ein zusätzliches Netz, welches auch wieder nicht mit allen kann. Aber dafür bastelt man fleissig Bridges bis keiner mehr weiss, was, wie und wo man alles verlinkt ist. :-)

vy 73
Zitieren
#39
(26.11.2016, 10:01)dj3ue schrieb: Ähm.....was genau meinst du damit? ;-)

YSF ist die Hausmarke....



Was is das?

https://c4fm.ysfreflector.de/

Du kannst natürlich auch was anderes als Netz in der .ini eintragen, wie es Dir gefällt....
Zitieren
#40
Die Seite kannte ich noch nicht.
Kein Wunder, ohne einen funktionierenden MMDVM komme ich da ja auch nich hin ;-)

Übrigens:
Im nächsten "Funkamateur" 1/17 ist ein Bericht angekündigt:
"C4FM-Fusion-Betrieb mit Wires-X"
FT-991 / FTM-400 / FT-1 / FT-1 / FTM-100
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste